Weirdest electrical fault ever!!

Discussion in 'Faults, Fixes and Solutions' started by M3crudge, Oct 10, 2020.

  1. 10 Oct 2020 at 11:40 AM #1
    M3crudge

    M3crudge On the path

    Joined:
    Apr 2, 2014
    Messages:
    114
    Likes Received:
    14
    Trophy Points:
    18
    Location:
    Essex
    What're you driving?:
    Supercharged E46 M3
    Colour Combo:
    Carbon black/Black Nappa Leather
    Hi all,
    Just wondering if anyone could shed some light on my weird cars fault and why it could be doing this??

    I have a 2003 e46 m3, currently looking for a battery drain issue atm so ive bought the hedgehog to replace (doing today), and while looking for the drain ive noticed that if the cars completely off and im sitting inside with keys out, i turn my lights on and the radio comes on!!!! Wtf! Could this be down to a bad earth somewhere?? Also, this has only just started to do this, wondering if somethings getting worse with the wiring..

    Sorry for the long winded post but its bugging me sooo bad. Lol.

    Thanks.
    Scott.
     
  2. 10 Oct 2020 at 12:47 PM #2
    Zletsgo

    Zletsgo Wearing official robes

    Joined:
    May 15, 2012
    Messages:
    347
    Likes Received:
    208
    Trophy Points:
    43
    What're you driving?:
    M3 Comp Pack
    Colour Combo:
    Nardo Grey
    Get some weird behaviour with failing earth straps sometimes - worth checking for sure
     
    M3crudge likes this.
  3. 14 Oct 2020 at 11:57 AM #3
    thomasj

    thomasj A mere Chipper

    Joined:
    Nov 21, 2016
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Surrey
    What're you driving?:
    2005 BMW M3 E46
    Colour Combo:
    Carbon Black / Black
    Any luck with the FSR? I've purchased one to help with mine, but haven't replaced it yet. Had one mechanic say to me that if my heaters are working fine, then I shouldn't need to replace the FSR....which is contrary to what some forum members have experienced.
     
  4. 14 Oct 2020 at 4:45 PM #4
    M3crudge

    M3crudge On the path

    Joined:
    Apr 2, 2014
    Messages:
    114
    Likes Received:
    14
    Trophy Points:
    18
    Location:
    Essex
    What're you driving?:
    Supercharged E46 M3
    Colour Combo:
    Carbon black/Black Nappa Leather
    Will reply here on weekend mate, not had time to replace it yet as always working. Finger crossed..
     
  5. 15 Oct 2020 at 7:46 PM #5
    M3crudge

    M3crudge On the path

    Joined:
    Apr 2, 2014
    Messages:
    114
    Likes Received:
    14
    Trophy Points:
    18
    Location:
    Essex
    What're you driving?:
    Supercharged E46 M3
    Colour Combo:
    Carbon black/Black Nappa Leather
    FSR changed today, will post my findings in a few days when the car has sat... fingers crossed that the battery will not drain... not sure what else it could be other than that.
     
  6. 17 Oct 2020 at 4:07 PM #6
    thomasj

    thomasj A mere Chipper

    Joined:
    Nov 21, 2016
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Surrey
    What're you driving?:
    2005 BMW M3 E46
    Colour Combo:
    Carbon Black / Black
    Good luck; keep us posted! Am waiting for time to do mine.
     
  7. 26 Oct 2020 at 1:04 PM #7
    cossie1

    cossie1 Achieved official socks

    Joined:
    Jul 2, 2010
    Messages:
    8,276
    Likes Received:
    3,022
    Trophy Points:
    113
    What're you driving?:
    2015 M4 Coupe
    Colour Combo:
    Mineral White / Black
    Sounds like an i-bus issue.

    I had a similar issue with a previous E46 M3, it started of whereby sometimes the digital display would go really dim and then suddenly go back to full brightness, it didn't really bother me but over the period of a couple of months I noticed more and more weird random things happening.

    The speedo cluster would randomly come on (you could walk past the car at night and see it illuminated), battery started to go flat over a couple of days if you didn't use the car everyday.

    In the end the indicator lights on the speedo would stay flashing even though you had cancelled the indicators, or they would stay on even though you were not indicating and then it got to the point that they wouldn't flash or come on at all, even when you were indicating and at the same time the radio control on the steering wheel would stop working.

    Sometimes it would be just a few seconds other times it could be for hours at a time.

    Eventually I traced the issue down to an old bmw i-pod adaptor that had been fitted (genuine bmw item) but no longer used, it had been partially disconnected behind the head unit, but the i-bus wiring was still connected.

    Once removed, all the issue's vanished and the battery never went flat again.
     

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice