Screenwash Not Working

Discussion in 'E46 M3 (2001-2006)' started by jay m3, Jan 9, 2018.

  1. 9 Jan 2018 at 5:13 PM #1
    jay m3

    jay m3 Registered User

    Joined:
    May 30, 2011
    Messages:
    580
    Likes Received:
    0
    Trophy Points:
    0
    I believe its the pump but can someone confirm.

    The wipers come on but no water? Cant hear the motor anymore either? What could it be? If it is the pump is it advised to buy original or are copies ok?
     
  2. 9 Jan 2018 at 5:19 PM #2
    zed650

    zed650 Registered User

    Joined:
    Apr 15, 2010
    Messages:
    1,886
    Likes Received:
    0
    Trophy Points:
    0
    This happened to me,I bought a new pump,I needed one ASAP and went to the local stealer who had one in stock,I think they’re cheaper at Euro car part etc
     
  3. 9 Jan 2018 at 5:25 PM #3
    SNS

    SNS Registered User

    Joined:
    Jan 2, 2015
    Messages:
    200
    Likes Received:
    0
    Trophy Points:
    0
    Yes had to replace mine a couple of years back. Euro or gsf.
    Located drivers front wheel arch, easy enough to change.
     
  4. 9 Jan 2018 at 7:10 PM #4
    bimbob

    bimbob Registered User

    Joined:
    Mar 22, 2012
    Messages:
    1,017
    Likes Received:
    0
    Trophy Points:
    0
    Daft question but, is there screenwash in the bottle and is it frozen. Might sound silly but things like this happen....
     
  5. 9 Jan 2018 at 7:20 PM #5
    jay m3

    jay m3 Registered User

    Joined:
    May 30, 2011
    Messages:
    580
    Likes Received:
    0
    Trophy Points:
    0
    Thanks for all your help!

    Not daft at all, could be a possiblilty. I'll be sure to check that out. Thank you :thumbsup:
     
  6. 12 Jan 2018 at 12:00 AM #6
    Seanjmoyle

    Seanjmoyle Registered User

    Joined:
    Jun 12, 2017
    Messages:
    313
    Likes Received:
    0
    Trophy Points:
    0
  7. 12 Jan 2018 at 12:01 AM #7
    Seanjmoyle

    Seanjmoyle Registered User

    Joined:
    Jun 12, 2017
    Messages:
    313
    Likes Received:
    0
    Trophy Points:
    0
    *repeated post deleted*
     
    Last edited: Jan 12, 2018
  8. 12 Jan 2018 at 2:22 PM #8
    jimyu

    jimyu Registered User

    Joined:
    Jun 11, 2013
    Messages:
    1,422
    Likes Received:
    0
    Trophy Points:
    0
  9. 12 Jan 2018 at 2:56 PM #9
    Caveman

    Caveman Registered User

    Joined:
    Dec 19, 2013
    Messages:
    1,274
    Likes Received:
    0
    Trophy Points:
    0
    Frozen water is an option and deffo clean out your filters in the bottle before doing anything - it will make a difference regardless.
     
    Last edited: Jan 12, 2018
  10. 12 Jan 2018 at 11:35 PM #10
    Seanjmoyle

    Seanjmoyle Registered User

    Joined:
    Jun 12, 2017
    Messages:
    313
    Likes Received:
    0
    Trophy Points:
    0
    I expect it won't be the only time either!
     
  11. 13 Jan 2018 at 12:56 AM #11
    dannyboy20

    dannyboy20 Registered User

    Joined:
    Oct 27, 2013
    Messages:
    621
    Likes Received:
    0
    Trophy Points:
    16
    Check the fuse? Operating the washer pumps when frozen can blow a fuse easy enough. If not a fuse put a multi meter on the pump and operate the washers. If you have a feed but the pumps not operating. Then you know its the pump. Easy enough to do
     

Share This Page