S50B30 base timing setting at idle

Discussion in 'E36 M3 (1991-1999) and E30 M3 (1986-1990)' started by finlay007, Oct 9, 2019.

  1. 9 Oct 2019 at 2:25 PM #1
    finlay007

    finlay007 A mere Chipper

    Joined:
    Jul 22, 2017
    Messages:
    31
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    Dunfermline
    Your Motor:
    E36 Compact S50
    hi all

    what should a stock s50b30 base timing setting at idle be ?

    much appreciated

    Fin
     
  2. 9 Oct 2019 at 5:37 PM #2
    Iain

    Iain Staff Member Moderator

    Joined:
    Apr 14, 2010
    Messages:
    4,105
    Likes Received:
    283
    Trophy Points:
    83
    Location:
    Isle of man
    Your Motor:
    AMG estate
    do you not have the timing marks on the cams?
     
  3. 9 Oct 2019 at 5:47 PM #3
    finlay007

    finlay007 A mere Chipper

    Joined:
    Jul 22, 2017
    Messages:
    31
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    Dunfermline
    Your Motor:
    E36 Compact S50
    thanks for reply, yea but im trying to check basing timing on engine against what my ecu is set at and if its off then reset to sync ecu and engine when i check with timing light, ive been given the setting of 6 deg adv at idle when warm by ECU company (SCS DELTA) so i was just wondering what other people had set theirs to

    cheers
     
  4. 9 Oct 2019 at 6:07 PM #4
    Iain

    Iain Staff Member Moderator

    Joined:
    Apr 14, 2010
    Messages:
    4,105
    Likes Received:
    283
    Trophy Points:
    83
    Location:
    Isle of man
    Your Motor:
    AMG estate
    6 degrees sounds sensible, I don't have any base figures as mine can be adjusted via the vanos.

    You should be able to check the advance on the cam with an angle gauge
     
    finlay007 likes this.
  5. 9 Oct 2019 at 6:41 PM #5
    finlay007

    finlay007 A mere Chipper

    Joined:
    Jul 22, 2017
    Messages:
    31
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    Dunfermline
    Your Motor:
    E36 Compact S50
    My exhaust is stock but inlet is set at 7 degrees as im not running a vanos system, just want to check everything as i have developed a missfire through rev after fitting a new oem crank sensor
     

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice