Need Help With INPA & DCAN - 2008 E91 LCI

Discussion in 'BMW Diagnostic, programming and software discussion' started by SLPM3, Sep 14, 2018.

  1. 14 Sep 2018 at 8:45 AM #1
    SLPM3

    SLPM3 Achieved official socks

    Joined:
    Jan 27, 2014
    Messages:
    964
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Detroitwich
    Your Motor:
    E36 M3 Evo Individual
    Colour Combo:
    Avus/Modena
    So i had a bcables cable and SW, but it wouldn't talk to my car as i learnt that the blue cable is only dcan up to 2007. Since the new daily is a 2008 (E91 325 LCI) car i purchased a K+DCAN cable, has a little switch to go between the two, and installed a new copy of INPA.

    I am running windows 10 pro, so installed it in XP SP2 compatibility mode, then installed the dcan drivers and set the ports to COM1. Not sure if that is part of the problem as it was showing COM1 in use, but still set it anyway.

    I think the cable is working as it will see when the ignition is toggled on/off and the black dot comes and goes as you toggle.

    Here is a video of the issue i get.

    https://youtu.be/f5Nzxo414-Y

    As you can see it lets me get so far into INPA then gives Ediabas error #95 when, for example, trying to read error codes. I also see that the program has stopped running, turns yellow, as soon as i enter the menu for my ECU and other than when i first plug the cable in, it doesn't seem to be lit up.

    Whats weird is if you watch the video to the end, 1min 25, i go into functional jobs in the E90 menu and read error memory and it will talk to the car, although it seems somewhat limited in the info.

    Any help would be greatly appreciated.
     
    Last edited: Sep 14, 2018

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice