Help needed X5 e53

Discussion in 'Carphonics' started by Simo72, Jul 19, 2016.

  1. 19 Jul 2016 at 11:30 PM #1
    Simo72

    Simo72 A mere Chipper

    Joined:
    Jul 7, 2016
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    0
    Your Motor:
    2003 BMW X5 3.0 d
    Hi all, am looking for help or advice please, I am new to bmws and recently purchased and oldish X5,e53,model, however the CD, player appears not to work, I found it located inside the side panel in the boot had a quick look and saw it wasn't plugged in, thought great just needs connecting , however after I plugged conectors in the cd powered up and ejected the 6 cd magazine which I loaded with CDs, this all worked fine but no sound would play, I thought the CD player was prob broke, so I purchased another one second hand which came with warranty and was assured is in good working order, plugged it in thinking this would sort problem, unfortunately this one does exactly the same, CDs all load fine and it shows they are playing but no sound, Has anybody else encountered this or have any ideas how to fix?? Thanks in advance
     
  2. 19 Jul 2016 at 11:41 PM #2
    Spyros

    Spyros Achieved official socks

    Joined:
    Feb 23, 2010
    Messages:
    823
    Likes Received:
    2
    Trophy Points:
    18
    Your Motor:
    E92 M3, Suzuki Jimny
    Colour Combo:
    Melbourne Red
    I'm presuming the radio works and it's not just that the speakers aren't plugged in? Does the head unit display suggest that it's selecting a track etc?
     
  3. 20 Jul 2016 at 9:28 AM #3
    Simo72

    Simo72 A mere Chipper

    Joined:
    Jul 7, 2016
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    0
    Your Motor:
    2003 BMW X5 3.0 d
    Hi, yes speakers work fine with radio, and sat nav, and cd display is all correct and shows track being played..
     
  4. 4 Aug 2016 at 6:09 PM #4
    XKaLiBaR

    XKaLiBaR Sponsor

    Joined:
    Oct 13, 2009
    Messages:
    11,106
    Likes Received:
    31
    Trophy Points:
    48
    Your Motor:
    E46 M3 Manual
    Colour Combo:
    Red/Red
    Most likely the audio input into your radio module called the bm54, has been disconnected, or you have something after market connected, like a parrot system.
     
  5. 6 Aug 2016 at 9:34 AM #5
    Simo72

    Simo72 A mere Chipper

    Joined:
    Jul 7, 2016
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    0
    Your Motor:
    2003 BMW X5 3.0 d
    Hi thanks, for reply, I located the bm54 near the battery, and didn't notice anything around that looked like it was unplugged. Any other suggestions?
     
  6. 6 Aug 2016 at 11:06 AM #6
    XKaLiBaR

    XKaLiBaR Sponsor

    Joined:
    Oct 13, 2009
    Messages:
    11,106
    Likes Received:
    31
    Trophy Points:
    48
    Your Motor:
    E46 M3 Manual
    Colour Combo:
    Red/Red
    Take a photo.

    Both connectors connected to the cd changer ?

    Has the car got DSP ?
     
  7. 8 Aug 2016 at 12:38 PM #7
    Simo72

    Simo72 A mere Chipper

    Joined:
    Jul 7, 2016
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    0
    Your Motor:
    2003 BMW X5 3.0 d
    Yes both connectors are on CD player, I will take a photo of bm54, also what is dsp?
     
  8. 8 Aug 2016 at 1:43 PM #8
    XKaLiBaR

    XKaLiBaR Sponsor

    Joined:
    Oct 13, 2009
    Messages:
    11,106
    Likes Received:
    31
    Trophy Points:
    48
    Your Motor:
    E46 M3 Manual
    Colour Combo:
    Red/Red
    Sound upgrade from factory. Big black amp on the left side of boot and subs on the right side. Plus DSP option on screen.
     
  9. 9 Aug 2016 at 11:14 AM #9
    Simo72

    Simo72 A mere Chipper

    Joined:
    Jul 7, 2016
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    0
    Your Motor:
    2003 BMW X5 3.0 d
    I'm really appreciating your help in trying to sort this, I have now taken pic of bum 54 and fuses etc, but I can't upload them on this forum, would it be ok to email you them?? Thanks
     
  10. 9 Aug 2016 at 11:14 AM #10
    Simo72

    Simo72 A mere Chipper

    Joined:
    Jul 7, 2016
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    0
    Your Motor:
    2003 BMW X5 3.0 d
    **bm54. Lol
     
  11. 9 Aug 2016 at 1:15 PM #11
    XKaLiBaR

    XKaLiBaR Sponsor

    Joined:
    Oct 13, 2009
    Messages:
    11,106
    Likes Received:
    31
    Trophy Points:
    48
    Your Motor:
    E46 M3 Manual
    Colour Combo:
    Red/Red
  12. 15 Aug 2016 at 10:32 PM #12
    Simo72

    Simo72 A mere Chipper

    Joined:
    Jul 7, 2016
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    0
    Your Motor:
    2003 BMW X5 3.0 d
    All sorted! Previous owner had something else plugged into the bm54, I located the cd plug by looking in area around the bm54, switched them over and CD player worked straight away, thanks for your help..
     

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice