E46 m3 cluster

Discussion in 'Faults, Fixes and Solutions' started by Grazzm3, Feb 8, 2018.

  1. 8 Feb 2018 at 8:13 PM #1
    Grazzm3

    Grazzm3 A mere Chipper

    Joined:
    Oct 20, 2013
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    0
    Your Motor:
    E46 m3
    Hey guys my car had been sat for a few weeks then I went to start her all was good started right away but I noticed that only 3 lights came on with ignition they were abs, air bag, and the funny bed looking one. Nothing else works speedo, fuel gauge, revs, nothing anyone had this problem??? I’ve checked the fuses and all seems ok. Thanks in advance
     
  2. 8 Feb 2018 at 9:04 PM #2
    Blingsta

    Blingsta Achieved official socks

    Joined:
    Sep 3, 2014
    Messages:
    1,504
    Likes Received:
    1
    Trophy Points:
    38
    Your Motor:
    M3 Cabby
    Try to disconnect and reconnect the battery
     
  3. 8 Feb 2018 at 9:05 PM #3
    Grazzm3

    Grazzm3 A mere Chipper

    Joined:
    Oct 20, 2013
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    0
    Your Motor:
    E46 m3
    Done that mate no joy
     
  4. 9 Feb 2018 at 7:16 PM #4
    Grazzm3

    Grazzm3 A mere Chipper

    Joined:
    Oct 20, 2013
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    0
    Your Motor:
    E46 m3
    Anyone????
     
  5. 9 Feb 2018 at 7:26 PM #5
    DJ Syxx

    DJ Syxx Achieved official socks

    Joined:
    Aug 8, 2010
    Messages:
    6,844
    Likes Received:
    4
    Trophy Points:
    38
    Location:
    London
    Your Motor:
    E46 M3
    Colour Combo:
    Stahl Grau & Cinnamon
    Flat battery, charge it or get some jump leads on.
     
  6. 9 Feb 2018 at 7:31 PM #6
    Grazzm3

    Grazzm3 A mere Chipper

    Joined:
    Oct 20, 2013
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    0
    Your Motor:
    E46 m3
    Battery is fine mate starts first time, just started her and drove her but nothing on dash apart from abs light
     
  7. 9 Feb 2018 at 7:33 PM #7
    E46CoupeM3

    E46CoupeM3 Achieved official socks

    Joined:
    Oct 31, 2012
    Messages:
    15,442
    Likes Received:
    56
    Trophy Points:
    48
    Location:
    England
    Your Motor:
    2001 BMW M3
    Colour Combo:
    Carbon Black
  8. 9 Feb 2018 at 7:49 PM #8
    Grazzm3

    Grazzm3 A mere Chipper

    Joined:
    Oct 20, 2013
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    0
    Your Motor:
    E46 m3
    I’ll try these mate. Cheers
     
  9. 9 Feb 2018 at 9:40 PM #9
    E46CoupeM3

    E46CoupeM3 Achieved official socks

    Joined:
    Oct 31, 2012
    Messages:
    15,442
    Likes Received:
    56
    Trophy Points:
    48
    Location:
    England
    Your Motor:
    2001 BMW M3
    Colour Combo:
    Carbon Black
    Fingers crossed
     
  10. 10 Feb 2018 at 10:11 AM #10
    Grazzm3

    Grazzm3 A mere Chipper

    Joined:
    Oct 20, 2013
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    0
    Your Motor:
    E46 m3
    Guys I just noticed also my roof doesn’t down, windows don’t auto going up (but they auto down) so obviously it’s an electrical problem but where do I start?? Is this all connected to one problem??
     
  11. 10 Feb 2018 at 10:46 AM #11
    E46CoupeM3

    E46CoupeM3 Achieved official socks

    Joined:
    Oct 31, 2012
    Messages:
    15,442
    Likes Received:
    56
    Trophy Points:
    48
    Location:
    England
    Your Motor:
    2001 BMW M3
    Colour Combo:
    Carbon Black
    ^Windows just need stops relearning - pretty normal
     
  12. 10 Feb 2018 at 12:27 PM #12
    Grazzm3

    Grazzm3 A mere Chipper

    Joined:
    Oct 20, 2013
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    0
    Your Motor:
    E46 m3
    All this has happened at the same time. So what about roof?? Is that the same problem as cluster not working??? Is it all in the same loom??? Could that be my problem
     
  13. 10 Feb 2018 at 2:07 PM #13
    E46CoupeM3

    E46CoupeM3 Achieved official socks

    Joined:
    Oct 31, 2012
    Messages:
    15,442
    Likes Received:
    56
    Trophy Points:
    48
    Location:
    England
    Your Motor:
    2001 BMW M3
    Colour Combo:
    Carbon Black
    Windows lose their stops sometimes when the battery goes flat so yes it would happen at the same time.

    Re roof no idea. However, you can panic or you can work the problems and not be paralysed by wondering
     
  14. 10 Feb 2018 at 8:46 PM #14
    Grazzm3

    Grazzm3 A mere Chipper

    Joined:
    Oct 20, 2013
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    0
    Your Motor:
    E46 m3
    Battery has never gone flat mate I left the car for couple weeks and I thought I better c if she turns over, she did and started first time, wasn’t till then I noticed that the cluster didn’t work. I’ll have a go at the other two options in the mean time
     
  15. 10 Feb 2018 at 8:48 PM #15
    E46CoupeM3

    E46CoupeM3 Achieved official socks

    Joined:
    Oct 31, 2012
    Messages:
    15,442
    Likes Received:
    56
    Trophy Points:
    48
    Location:
    England
    Your Motor:
    2001 BMW M3
    Colour Combo:
    Carbon Black
    Interesting. Nothing to lose in the trying though, so worth a go
     
  16. 10 Feb 2018 at 8:53 PM #16
    Grazzm3

    Grazzm3 A mere Chipper

    Joined:
    Oct 20, 2013
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    0
    Your Motor:
    E46 m3
    Ye I guess that’s all I can do. Cluster was working before it was sat for couple weeks. Maybe I got water/moisture in the engine bay as I have massive gtr bonnet vents installed
     
  17. 10 Feb 2018 at 8:54 PM #17
    E46CoupeM3

    E46CoupeM3 Achieved official socks

    Joined:
    Oct 31, 2012
    Messages:
    15,442
    Likes Received:
    56
    Trophy Points:
    48
    Location:
    England
    Your Motor:
    2001 BMW M3
    Colour Combo:
    Carbon Black
    There's not really anything under there to get wet through the vents that influences cluster or central body electronics though
     
  18. 10 Feb 2018 at 8:55 PM #18
    Grazzm3

    Grazzm3 A mere Chipper

    Joined:
    Oct 20, 2013
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    0
    Your Motor:
    E46 m3
    Will disconnecting the ecu and reconnecting it do anything??
     
  19. 10 Feb 2018 at 8:55 PM #19
    E46CoupeM3

    E46CoupeM3 Achieved official socks

    Joined:
    Oct 31, 2012
    Messages:
    15,442
    Likes Received:
    56
    Trophy Points:
    48
    Location:
    England
    Your Motor:
    2001 BMW M3
    Colour Combo:
    Carbon Black
    Every module is an ECU
     
  20. 12 Feb 2018 at 1:13 PM #20
    Grazzm3

    Grazzm3 A mere Chipper

    Joined:
    Oct 20, 2013
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    0
    Your Motor:
    E46 m3
    So I checked all the fuses and there all ok. Disconnected t and reconnected the cluster but still nothing, guess I’ll have to get it plugged in
     

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice