The M3cutters - UK BMW M3 Group Forum
 

Go Back   The M3cutters - UK BMW M3 Group Forum > M3 and M4 Talk > E90 Saloon / E92 Coupe / E93 Convertible M3 (2008-2013)



Reply
 
Thread Tools Display Modes
Old 4th October 2017, 05:42 PM   #1
Desmo
On the path
 
Desmo's Avatar
 
Join Date: Dec 2016
Location: Fleet
Posts: 76
Car: 2012 E92 M3 LE500 DCT
Colour Combo: Mineral White & Fox
Default Is this a problematic ABS Sensor?

So I exit the motorway and sweep to the left and brake at the roundabout. Get a judder from the brake pedal that feels like the ABS kicking in. Conditions are dry.
Desmo is offline   Reply With Quote
Sponsored links
Old 4th October 2017, 05:46 PM   #2
E46CoupeM3
Achieved official socks
 
E46CoupeM3's Avatar
 
Join Date: Oct 2012
Location: England
Posts: 12,654
Car: 2001 BMW M3
Colour Combo: Carbon Black
Default

If there is no ABS light would normally be warped discs
E46CoupeM3 is offline   Reply With Quote
Old 17th October 2017, 08:51 PM   #3
Desmo
On the path
 
Desmo's Avatar
 
Join Date: Dec 2016
Location: Fleet
Posts: 76
Car: 2012 E92 M3 LE500 DCT
Colour Combo: Mineral White & Fox
Default

Quote:
Originally Posted by E46CoupeM3 View Post
If there is no ABS light would normally be warped discs
Wouldn't that show itself in straight line braking?

It did it again the other day. Same conditions
Desmo is offline   Reply With Quote
Old 18th October 2017, 04:54 PM   #4
GHD129
Wearing official underwear
 
GHD129's Avatar
 
Join Date: Dec 2015
Location: Glossop
Posts: 159
Car: Audi RS3 Sportback
Colour Combo: White/Black
Default

If it's a failed ABS sensor you will get a multitude of warning signs on the idrive screen. Unless you've got that it won't be a sensor. Not sure if it's a pump problem. Are you getting any info on the screen indicating a fault?
GHD129 is offline   Reply With Quote
Old 18th October 2017, 06:10 PM   #5
ndj
Rocking a new hat
 
ndj's Avatar
 
Join Date: Jan 2012
Location: St. Andrews
Posts: 559
Car: E90 M3 LCI
Colour Combo: Jerez / Novillo Fox Red
Default

I've experienced a similar situation prior to an ABS sensor dying.

Continued intermittently between the dash finally lighting up and me getting it in for repair.
ndj is offline   Reply With Quote
Old 18th October 2017, 07:10 PM   #6
m3inter
Achieved official socks
 
m3inter's Avatar
 
Join Date: Jan 2009
Location: Surrey
Posts: 1,004
Car: 2002 BMW M3 Coupe
Default

Sounds like a failing wheel speed sensor to me.
m3inter is offline   Reply With Quote
Old 20th October 2017, 05:34 AM   #7
Desmo
On the path
 
Desmo's Avatar
 
Join Date: Dec 2016
Location: Fleet
Posts: 76
Car: 2012 E92 M3 LE500 DCT
Colour Combo: Mineral White & Fox
Default

Quote:
Originally Posted by m3inter View Post
Sounds like a failing wheel speed sensor to me.
That's what I thought. Thanks
Desmo is offline   Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes



All times are GMT. The time now is 11:59 PM.


This website uses cookies. By continuing to use the site you are agreeing to our use of cookies. To find out more about the cookies this website uses, click here.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright © 2007 - 2014 M3cutters. All Rights Reserved.