The M3cutters - UK BMW M3 Group Forum
 

Go Back   The M3cutters - UK BMW M3 Group Forum > M3 and M4 Talk > E46 M3 (2001-2006)



Reply
 
Thread Tools Display Modes
Old 9th January 2018, 05:13 PM   #1
jay m3
Rocking a new hat
 
jay m3's Avatar
 
Join Date: May 2011
Location: London
Posts: 556
Car: 2004 M3 VERT
Colour Combo: CARBON BLACK
Default Screenwash Not Working

I believe its the pump but can someone confirm.

The wipers come on but no water? Cant hear the motor anymore either? What could it be? If it is the pump is it advised to buy original or are copies ok?
jay m3 is offline   Reply With Quote
Sponsored links
Old 9th January 2018, 05:19 PM   #2
zed650
Achieved official socks
 
zed650's Avatar
 
Join Date: Apr 2010
Posts: 1,608
Car: 2004 M3 COUPE CSL
Colour Combo: ESTORIL BLUE / BLACK
Default

This happened to me,I bought a new pump,I needed one ASAP and went to the local stealer who had one in stock,I think they’re cheaper at Euro car part etc
zed650 is offline   Reply With Quote
Old 9th January 2018, 05:25 PM   #3
SNS
Wearing official underwear
 
SNS's Avatar
 
Join Date: Jan 2015
Location: Oxford
Posts: 163
Car: E46 M3
Colour Combo: Imola / black
Default

Yes had to replace mine a couple of years back. Euro or gsf.
Located drivers front wheel arch, easy enough to change.
SNS is offline   Reply With Quote
Old 9th January 2018, 07:10 PM   #4
bimbob
Achieved official socks
 
bimbob's Avatar
 
Join Date: Mar 2012
Posts: 940
Car: E46 M3
Default

Daft question but, is there screenwash in the bottle and is it frozen. Might sound silly but things like this happen....
bimbob is offline   Reply With Quote
Old 9th January 2018, 07:20 PM   #5
jay m3
Rocking a new hat
 
jay m3's Avatar
 
Join Date: May 2011
Location: London
Posts: 556
Car: 2004 M3 VERT
Colour Combo: CARBON BLACK
Default

Thanks for all your help!

Quote:
Originally Posted by bimbob View Post
Daft question but, is there screenwash in the bottle and is it frozen. Might sound silly but things like this happen....
Not daft at all, could be a possiblilty. I'll be sure to check that out. Thank you
jay m3 is offline   Reply With Quote
Old 12th January 2018, 12:00 AM   #6
Seanjmoyle
Wearing official underwear
 
Seanjmoyle's Avatar
 
Join Date: Jun 2017
Location: Plymouth
Posts: 191
Car: 05 Titan M3 + C250 + A1 S line
Default

See post #4 on my thread, the tiny filter was blocked and the washer bottle very grimey before flushing through.

http://forums.m3cutters.co.uk/showthread.php?t=180222
Seanjmoyle is offline   Reply With Quote
Old 12th January 2018, 12:01 AM   #7
Seanjmoyle
Wearing official underwear
 
Seanjmoyle's Avatar
 
Join Date: Jun 2017
Location: Plymouth
Posts: 191
Car: 05 Titan M3 + C250 + A1 S line
Default

*repeated post deleted*

Last edited by Seanjmoyle; 12th January 2018 at 12:03 AM.
Seanjmoyle is offline   Reply With Quote
Old 12th January 2018, 02:22 PM   #8
jimyu
Achieved official socks
 
jimyu's Avatar
 
Join Date: Jun 2013
Posts: 1,345
Car: E46 M3, Z4MC, Yamaha MT-07
Default

Quote:
Originally Posted by Seanjmoyle View Post
See post #4 on my thread, the tiny filter was blocked and the washer bottle very grimey before flushing through.

http://forums.m3cutters.co.uk/showthread.php?t=180222
I had this too on my M3 and also Z4
jimyu is offline   Reply With Quote
Old 12th January 2018, 02:56 PM   #9
Caveman
Rocking a new hat
 
Caveman's Avatar
 
Join Date: Dec 2013
Location: Gerrards Cross, Bucks
Posts: 541
Car: 2002 M3 Convertible
Colour Combo: Carbon Black/ Black / Black
Default

Frozen water is an option and deffo clean out your filters in the bottle before doing anything - it will make a difference regardless.

Last edited by Caveman; 12th January 2018 at 04:32 PM.
Caveman is offline   Reply With Quote
Old 12th January 2018, 11:35 PM   #10
Seanjmoyle
Wearing official underwear
 
Seanjmoyle's Avatar
 
Join Date: Jun 2017
Location: Plymouth
Posts: 191
Car: 05 Titan M3 + C250 + A1 S line
Default

Quote:
Originally Posted by jimyu View Post
I had this too on my M3 and also Z4
I expect it won't be the only time either!
Seanjmoyle is offline   Reply With Quote
Old 13th January 2018, 12:56 AM   #11
dannyboy20
Rocking a new hat
 
dannyboy20's Avatar
 
Join Date: Oct 2013
Location: Chelmsford, Essex
Posts: 562
Car: CB E46 M3, Focus daily,
Default

Check the fuse? Operating the washer pumps when frozen can blow a fuse easy enough. If not a fuse put a multi meter on the pump and operate the washers. If you have a feed but the pumps not operating. Then you know its the pump. Easy enough to do
dannyboy20 is offline   Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes



All times are GMT. The time now is 06:32 AM.


This website uses cookies. By continuing to use the site you are agreeing to our use of cookies. To find out more about the cookies this website uses, click here.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright © 2007 - 2014 M3cutters. All Rights Reserved.