The M3cutters - UK BMW M3 Group Forum
 

Go Back   The M3cutters - UK BMW M3 Group Forum > Forum Sponsors and Advertisers > Carphonics



Reply
 
Thread Tools Display Modes
Old 19th July 2016, 10:30 PM   #1
Simo72
A mere Chipper
 
Simo72's Avatar
 
Join Date: Jul 2016
Posts: 13
Car: 2003 BMW X5 3.0 d
Default Help needed X5 e53

Hi all, am looking for help or advice please, I am new to bmws and recently purchased and oldish X5,e53,model, however the CD, player appears not to work, I found it located inside the side panel in the boot had a quick look and saw it wasn't plugged in, thought great just needs connecting , however after I plugged conectors in the cd powered up and ejected the 6 cd magazine which I loaded with CDs, this all worked fine but no sound would play, I thought the CD player was prob broke, so I purchased another one second hand which came with warranty and was assured is in good working order, plugged it in thinking this would sort problem, unfortunately this one does exactly the same, CDs all load fine and it shows they are playing but no sound, Has anybody else encountered this or have any ideas how to fix?? Thanks in advance
Simo72 is offline   Reply With Quote
Old 19th July 2016, 10:41 PM   #2
Spyros
Achieved official socks
 
Spyros's Avatar
 
Join Date: Feb 2010
Posts: 750
Car: Golf 7R, Suzuki Jimny (both Ferrari red)
Default

I'm presuming the radio works and it's not just that the speakers aren't plugged in? Does the head unit display suggest that it's selecting a track etc?
Spyros is offline   Reply With Quote
Old 20th July 2016, 08:28 AM   #3
Simo72
A mere Chipper
 
Simo72's Avatar
 
Join Date: Jul 2016
Posts: 13
Car: 2003 BMW X5 3.0 d
Default

Hi, yes speakers work fine with radio, and sat nav, and cd display is all correct and shows track being played..
Simo72 is offline   Reply With Quote
Old 4th August 2016, 05:09 PM   #4
XKaLiBaR
Site Sponsor
 
XKaLiBaR's Avatar
 
Join Date: Oct 2009
Location: London
Posts: 11,052
Car: E46 M3 Manual
Colour Combo: Red/Red
Default

Most likely the audio input into your radio module called the bm54, has been disconnected, or you have something after market connected, like a parrot system.
XKaLiBaR is offline   Reply With Quote
Old 6th August 2016, 08:34 AM   #5
Simo72
A mere Chipper
 
Simo72's Avatar
 
Join Date: Jul 2016
Posts: 13
Car: 2003 BMW X5 3.0 d
Default

Hi thanks, for reply, I located the bm54 near the battery, and didn't notice anything around that looked like it was unplugged. Any other suggestions?
Simo72 is offline   Reply With Quote
Old 6th August 2016, 10:06 AM   #6
XKaLiBaR
Site Sponsor
 
XKaLiBaR's Avatar
 
Join Date: Oct 2009
Location: London
Posts: 11,052
Car: E46 M3 Manual
Colour Combo: Red/Red
Default

Quote:
Originally Posted by Simo72 View Post
Hi thanks, for reply, I located the bm54 near the battery, and didn't notice anything around that looked like it was unplugged. Any other suggestions?
Take a photo.

Both connectors connected to the cd changer ?

Has the car got DSP ?
XKaLiBaR is offline   Reply With Quote
Old 8th August 2016, 11:38 AM   #7
Simo72
A mere Chipper
 
Simo72's Avatar
 
Join Date: Jul 2016
Posts: 13
Car: 2003 BMW X5 3.0 d
Default

Yes both connectors are on CD player, I will take a photo of bm54, also what is dsp?
Simo72 is offline   Reply With Quote
Old 8th August 2016, 12:43 PM   #8
XKaLiBaR
Site Sponsor
 
XKaLiBaR's Avatar
 
Join Date: Oct 2009
Location: London
Posts: 11,052
Car: E46 M3 Manual
Colour Combo: Red/Red
Default

Sound upgrade from factory. Big black amp on the left side of boot and subs on the right side. Plus DSP option on screen.
XKaLiBaR is offline   Reply With Quote
Old 9th August 2016, 10:14 AM   #9
Simo72
A mere Chipper
 
Simo72's Avatar
 
Join Date: Jul 2016
Posts: 13
Car: 2003 BMW X5 3.0 d
Default

I'm really appreciating your help in trying to sort this, I have now taken pic of bum 54 and fuses etc, but I can't upload them on this forum, would it be ok to email you them?? Thanks
Simo72 is offline   Reply With Quote
Old 9th August 2016, 10:14 AM   #10
Simo72
A mere Chipper
 
Simo72's Avatar
 
Join Date: Jul 2016
Posts: 13
Car: 2003 BMW X5 3.0 d
Default

**bm54. Lol
Simo72 is offline   Reply With Quote
Old 9th August 2016, 12:15 PM   #11
XKaLiBaR
Site Sponsor
 
XKaLiBaR's Avatar
 
Join Date: Oct 2009
Location: London
Posts: 11,052
Car: E46 M3 Manual
Colour Combo: Red/Red
Default

Yes, [email protected]
XKaLiBaR is offline   Reply With Quote
Old 15th August 2016, 09:32 PM   #12
Simo72
A mere Chipper
 
Simo72's Avatar
 
Join Date: Jul 2016
Posts: 13
Car: 2003 BMW X5 3.0 d
Default

All sorted! Previous owner had something else plugged into the bm54, I located the cd plug by looking in area around the bm54, switched them over and CD player worked straight away, thanks for your help.. ����
Simo72 is offline   Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes



All times are GMT. The time now is 05:56 PM.


This website uses cookies. By continuing to use the site you are agreeing to our use of cookies. To find out more about the cookies this website uses, click here.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright © 2007 - 2018 M3cutters. All Rights Reserved.