The M3cutters - UK BMW M3 Group Forum
 

Go Back   The M3cutters - UK BMW M3 Group Forum > M3cutters Garage > Faults, Fixes and Solutions



Reply
 
Thread Tools Display Modes
Old 16th February 2018, 11:23 AM   #21
equinoxuk
Rocking a new hat
 
equinoxuk's Avatar
 
Join Date: Jul 2015
Location: South East
Posts: 544
Car: BMW 02 E46 M3, BMW 18 140i Msport
Colour Combo: Manual / Silver / Imola Red
Default

Had this recently disconnected it and plugged it back in. This resolved the issue for a short while.

Issue came back last weekend its now off at a cluster repair specialist at Waltham Abbey for investigation / repair.
equinoxuk is offline   Reply With Quote
Sponsored links
Old 16th February 2018, 06:05 PM   #22
Grazzm3
A mere Chipper
 
Grazzm3's Avatar
 
Join Date: Oct 2013
Posts: 32
Car: E46 m3
Default

How much do they charge?? I’m gunna run diagnostics in morn see what that picks up
Grazzm3 is offline   Reply With Quote
Old 16th February 2018, 07:52 PM   #23
Grazzm3
A mere Chipper
 
Grazzm3's Avatar
 
Join Date: Oct 2013
Posts: 32
Car: E46 m3
Default

Does anyone think it could be the battery! As (unless I’m over thinking it) the windows seem rather slow going up when I close the doors. (Convertible)
Grazzm3 is offline   Reply With Quote
Old 16th February 2018, 07:53 PM   #24
E46CoupeM3
Achieved official socks
 
E46CoupeM3's Avatar
 
Join Date: Oct 2012
Location: England
Posts: 15,064
Car: 2001 BMW M3
Colour Combo: Carbon Black
Default

Are the windows a lot quicker with engine running?
E46CoupeM3 is offline   Reply With Quote
Old 16th February 2018, 07:57 PM   #25
Grazzm3
A mere Chipper
 
Grazzm3's Avatar
 
Join Date: Oct 2013
Posts: 32
Car: E46 m3
Default

Na same. I plugged in the car and no codes came up. I noticed that now the central locking doesn’t work now nor does the boot button work ��. When I push the roof button down the red light comes on what that mean
Grazzm3 is offline   Reply With Quote
Old 16th February 2018, 11:03 PM   #26
Grazzm3
A mere Chipper
 
Grazzm3's Avatar
 
Join Date: Oct 2013
Posts: 32
Car: E46 m3
Default

Are the roof and windows etc on the same wiring harness
Grazzm3 is offline   Reply With Quote
Old 24th April 2018, 07:47 PM   #27
NUTINRILA
Achieved official socks
 
NUTINRILA's Avatar
 
Join Date: Oct 2009
Location: AYRSHIRE
Posts: 1,046
Car: ///M
Colour Combo: STEEL GREY COUPE
Default

Well guess what?

This has just happened to mine too.


After being off the road all winter I wanted to get it out back on the road, charged the battery and thought that I’d be out in it no time

Wrong!

Ended up with a faulty TPS and limp mode activated from first start up, other than that car was fine.
Long story short of that was I changed the top sensor which didn’t work, so stripped the air box etc out and done the bottom one.

Before I started doing said job I started the car up just in case it had cleared which it hadn’t but all of a sudden no instrument cluster lights, fuel, mph etc!!

I thought I’ll worry about it later and got to work on the TPS which was actually easy and fixed the throttle just fine.



Now I’m stuck with my head up my ar5e wondering what the hell is going on with my electrics

I have no instrument cluster, no boot open button, my window is intermittent on going back up when the door closes, and strangely the exterior AC fan is on permanently

A google search is bringing up topics of the k bus but I am completely hopeless with electrics, diagnostic equipment, scanners or any of that stuff.

I’d much rather build an engine than get into that however burying my head in the sand won’t help.

So can anyone help with tracing this issue?
NUTINRILA is offline   Reply With Quote
Old 24th April 2018, 07:51 PM   #28
E46CoupeM3
Achieved official socks
 
E46CoupeM3's Avatar
 
Join Date: Oct 2012
Location: England
Posts: 15,064
Car: 2001 BMW M3
Colour Combo: Carbon Black
Default

Try cluster self test
If no power to try self test check out wiring diagrams for power and earth and check them

You can run clusters and other modules up on the floor with minimum wiring, but if it is definitely powered and no self test it's internally dead
E46CoupeM3 is offline   Reply With Quote
Old 24th April 2018, 08:21 PM   #29
NUTINRILA
Achieved official socks
 
NUTINRILA's Avatar
 
Join Date: Oct 2009
Location: AYRSHIRE
Posts: 1,046
Car: ///M
Colour Combo: STEEL GREY COUPE
Default

How do you do a cluster self test?

My boot opens fine when I unlock my the car, when I start the engine it stops working

Also no radio or nav screen but the buttons are illuminated

My cluster shows seat beast and airbag light
NUTINRILA is offline   Reply With Quote
Old 24th April 2018, 08:30 PM   #30
E46CoupeM3
Achieved official socks
 
E46CoupeM3's Avatar
 
Join Date: Oct 2012
Location: England
Posts: 15,064
Car: 2001 BMW M3
Colour Combo: Carbon Black
Default

Was the battery completely flat?

Did you charge on or off the car?


As you say you are hopeless you probably need someone to fix it for you eventually.

This assumes you have done basics like check all fuses and charge battery while disconnected before even asking
E46CoupeM3 is offline   Reply With Quote
Old 24th April 2018, 09:01 PM   #31
NUTINRILA
Achieved official socks
 
NUTINRILA's Avatar
 
Join Date: Oct 2009
Location: AYRSHIRE
Posts: 1,046
Car: ///M
Colour Combo: STEEL GREY COUPE
Default

Maybe a bit harsh on my self with the hopeless chat but I don’t have testers or laptops for plugging in etc.

Battery was dead, removed from the car and fully charged.

I Removed the fuses 10, 34, 43

Removed them and started the car, shut it off and replaced the them started back up but still nothing
NUTINRILA is offline   Reply With Quote
Old 25th April 2018, 04:23 PM   #32
E46CoupeM3
Achieved official socks
 
E46CoupeM3's Avatar
 
Join Date: Oct 2012
Location: England
Posts: 15,064
Car: 2001 BMW M3
Colour Combo: Carbon Black
Default

Well you took the battery off to charge so did the right thing there as car completely disconnected for a while so not likely to be "browned out" charging

I don't know why you ran with fuses out though.
E46CoupeM3 is offline   Reply With Quote
Old 25th April 2018, 04:24 PM   #33
E46CoupeM3
Achieved official socks
 
E46CoupeM3's Avatar
 
Join Date: Oct 2012
Location: England
Posts: 15,064
Car: 2001 BMW M3
Colour Combo: Carbon Black
Default

Cluster self test is a guicl search on YouTube
Seeing is better than saying
E46CoupeM3 is offline   Reply With Quote
Old 25th April 2018, 07:33 PM   #34
NUTINRILA
Achieved official socks
 
NUTINRILA's Avatar
 
Join Date: Oct 2009
Location: AYRSHIRE
Posts: 1,046
Car: ///M
Colour Combo: STEEL GREY COUPE
Default

Ok mate Iíll have a check thanks

Got a multimeter today and my battery was reading 12.3 then 13.8 with the engine running.

That was after it getting a full charge, wondering if itís a little low?
NUTINRILA is offline   Reply With Quote
Old 25th April 2018, 07:49 PM   #35
E46CoupeM3
Achieved official socks
 
E46CoupeM3's Avatar
 
Join Date: Oct 2012
Location: England
Posts: 15,064
Car: 2001 BMW M3
Colour Combo: Carbon Black
Default

Quote:
Originally Posted by NUTINRILA View Post
Ok mate Iíll have a check thanks

Got a multimeter today and my battery was reading 12.3 then 13.8 with the engine running.

That was after it getting a full charge, wondering if itís a little low?
Perfectly fine.

13.8 to 14.4 are typical running values
E46CoupeM3 is offline   Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes



All times are GMT. The time now is 10:55 PM.


This website uses cookies. By continuing to use the site you are agreeing to our use of cookies. To find out more about the cookies this website uses, click here.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright © 2007 - 2018 M3cutters. All Rights Reserved.